Tuesday, February 28, 2017

*FIXED* Setting you Railo / Lucee server to use TLS 1.2 by setting to use Java 1.8 instead of Java 1.7.

TLS 1.0 support is being dropped by more and more platforms. If you are using your Railo / Lucee server to communicate with the service that have dropped the support using TLS 1.0, the request will not be honored. Here are the steps to have your Railo/Lucee server to use Java 1.8 instead of 1.7 and avoid this error.

First verify the version of Java that your Railo Server is using.
Go to Server Admin and check the version of Java used by Railo server. Instead of the 1.8.xx as show in the screenshot it will be 1.7.xx


So, we need to install JDK 1.8 if not yet installed in the machine.


  • Install JDK 1.8. 32/64 bit according to your server OS.
  • Open Railo-Tomcat Service Control.
  • Stop Railo.

  • In the Java tab, give the jvm of the newly installed JDK. Something like C:\Program Files\Java\jdk1.8.0_121\jre\bin\server\jvm.dll.
  • Restart Railo.


Check the version of Java used in Railo Server Admin, it will be 1.8.

Now your requests to the server will be TLS 1.2 and they will be honored.

1 comment:

Railo fan said...

Just wanted to say thank you for this! Now that Stripe requires TLS 1.2, this was super helpful.